Connecting to your ATEM switcher

From Skaarhoj
Jump to: navigation, search

This tutorial will instruct you how to establish a connection between your SKAARHOJ device and a ATEM switcher. The purpose is simply to make sure the two units can communicate. No actual programming is presented in this tutorial.

What you need:

  • SKAARHOJ Controller
  • Programming cable (either USB A/B or FTDI programming depending on model)
  • IF you have a model with FTDI connection follow step 2 to step 4 at Programming an Arduino Ethernet to install the FTDI chip driver (this is important!)
  • Arduino IDE (get it here Arduino.cc)

MAC

This demo is performed on Mac OS 10.8.2 (Mountaion Lion) with Arduino IDE 1.01

Step 1: Download ATEM Library

Download the ATEM library from Github at downloads the repository ATEM Download.png

Step 2: Rename Library

Rename the downloaded folder to ATEM

Step 3: Create Folder

Create folder Libraries in your Arduino folder in documents (/Users/Your Username/Arduino/Libraries/) ATEM Folder.png

Step 4: Move ATEM Folder

Move the ATEM folder to the Libraries folder just created

Step 5: Open Arduino IDE

Open Arduino.app

Step 6: Set the right Board

Set your board in Tools -> Board to either Arduino Ethernet or Arduino Mega 2560 or Mega ADK

Step 7: Open Monitor Sketch

Open the ATEMmonitor sketch in File -> Examples -> ATEM -> ATEMmonitor ATEM Monitor.png

Step 8: Setup Sketch

The lines with // <= SETUP needs information with an IP + MAC address for your SKAARHOJ device aswell as the ATEM switcher (needs to be on same subnet!).

By default (unless otherwise stated) the IP address for the SKAARHOJ unit is always set to 192.168.10.99 and 192.168.10.240 for the ATEM switchers in all SKAARHOJ libraries.

See Confirm IP of ATEM to change or confirm the IP address of your ATEM Switcher.

Step 9: Upload Sketch

Upload sketch ArduinoEthernet Upload.png

Step 10: Connection Type

Chose your serial port corresponding to your connection type (usbmodem or FTDI)

Step 11: Serial Monitor

Open Serial Monitor in Tools -> Serial Monitor

Step 12: Confirm

Confirm connection by observing the serial monitor.

PC

Comming soon